Hobione's Weblog

Living & Breathing in Web 2.0 Era

Netbeans 6.1: jax-rpc error

I downloaded Netbeans 6.1 and I was having the following compiling error with one of my existing application.

taskdef class org.netbeans.modules.websvc.jaxrpc.ant.WsClientUpToDate cannot be found

I Googled the error and here what I found a great answer from Jarek.
Hi,
yes, JAX-RPC is part of J2EE 1.4 and Netbeans 6.0 supports J2EE1.4, but JAX-RPC web services support is only one part of it and not everyone is using it, so it was decided
to move it to update center. You can still create J2EE1.4 web or ejb projects,for example, but to create JAX-RPC web service or client,JAX-RPC plugin is needed. You can easily install it through Tools/Plugins,there’s bunch of info messages to guide you and it’s still supported.
-Jarek

I have followed Jarek suggestion and downloaded jax-rpc webservices plugin and it worked.  Netbeans Rock!

Advertisements

April 28, 2008 - Posted by | Netbeans IDE | ,

1 Comment »

  1. Thank you soo much for giving this hint… ;)

    Comment by Rizwan Ali | September 14, 2010 | Reply


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: